Регистрация

Помощь для клиентов

DLE - Fatal error: 'continue' operator with non-constant operand is no longer supported

Поиск по статьям

При обновлении версии версии PHP до версии выше, например, до 5.4.x, некоторые пользователи старых версий DataLife Engine могут столкнуть с ошибкой вида:

Fatal error: 'continue' operator with non-constant operand is no longer supported in/var/www/user1/data/www/site.ru/engine/classes/torrent.class.php on line 326
Решение проблемы

Для решения проблемы нужно поменять версию PHP на более старую - 5.3 или же 5.2. Также, правильно будет обновить версию DLE до современной.

Пользователям ISPmanager 5

Если Вы используете ISPManager 5, то поменять версию можно через ISPManager 5. Для этого перейдите в раздел «WWW домены», два раза нажмите на нужный домен,  выберите нужную версию PHP, нажмите на кнопку «ОК».